Back to overview
Degraded
Outbound sending is delayed
Dec 17 at 02:14am PST
Affected services
Email Delivery
Resolved
Dec 17 at 03:17am PST
Message queues have lower wait times and new messages are sending quickly.
Affected services
Created
Dec 17 at 02:14am PST
Newly submitted mail is sending much faster now. Some emails that were sent earlier are still queued up, but the team is working to get those out as soon as possible.
Affected services