Back to overview
Degraded

Degraded Services for SMS communication

Jan 18 at 08:30am PST
Affected services
SMS, Europe
SMS, APAC
Voice - North America
Voice - APAC

Resolved
Jan 18 at 08:45am PST

Degraded services resolved.

Created
Jan 18 at 08:30am PST

Degraded Services for SMS communication